Question about 2005 Ford Escape

1 Answer

Replacing the battery

After replacing my battery now my gauges and radio dont work

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 5,158 Answers

Check your fuses

Robert

Posted on Sep 04, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 ford focus instr.cluster does not work the fuel gauge rpm and speedometer and odometer dont light up


so the only thing not working is the fuel gauge? the odometer , speedometer , and rpm gauge work, but dont light up? if so, does the radio or any other lights illuminate? check your dimmer switch for these issues. please let me know a little more information

Nov 04, 2012 | Cars & Trucks

1 Answer

I was testing a new radio to se if it worked. Now the fuel gauge and amp gauge dont work. when I check for power on the radio leads the temp gauge goes all the way up and fuel goes below e. All of the


I would sugest when the temp gauge goes up you are actually earthing the wire for the temp guage. I think you have entered the wrong harness for the wires & you have connected the radio to your guages. Remove radio & reconnect wires where they were before.

Jun 29, 2012 | 1992 Chevrolet S-10

1 Answer

Battery replaced. Now, wipers, dash gauges, locks dont work and headlights stay on?


check all the fuses and replace any that are blown. also check beattery wires and make sure the positive wires are not touching anything metal.look for burnt marks or black spots on the wires too. also have the battery fuse/relay checked.

Jan 24, 2012 | 2004 Dodge Grand Caravan

1 Answer

2003 monte carlo voltage gauge drops to zero, battery light comes


G'day mate there is also a main fuse with high amp fuses located near battery check each fuses by pulling out and checking for condition ie loose wobbly also weird as it may seem i have found a number of vehicles in which the ants have made a nest in the fuse box/s, dont know why just found it od , what they do is ends up with tracks to earth from nest for positive curciut, try that.

Mar 29, 2010 | 2003 Chevrolet Monte Carlo

1 Answer

2001 alero replaced factory radio now gas gauge and speedometer dont work any suggestions thanks


Take the radio out again and check for a wiring connector which was knocked loose during the radio installation.

Charlie

Aug 23, 2009 | 2001 Oldsmobile Alero

2 Answers

Car wont start radio,wipers,gauges,turn signals dont work


Check the battery cable ends to be sure they are tight and wont twist, I had this happen on my 96 grand caravan two years ago.

Aug 21, 2009 | 1996 Dodge Caravan

1 Answer

1996 gmc safari gauges not working


When the bonnet was removed the antenna wire was pulled loose. It is a ground for several components and when it was plugged back in everything came back to life.

Dec 26, 2008 | 1998 GMC Safari

2 Answers

Gauges not working


you should check all of the fuses. every one even the ones you dont think are related.good luck.

Nov 21, 2008 | 1996 Dodge Dakota

1 Answer

Battery


check the fuses... if they are ok... unhook the battery to reset everything and try again.

Robert

Sep 04, 2008 | 2005 Ford Escape

Not finding what you are looking for?
2005 Ford Escape Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...