Tip & How-To about Ford Escort

Blower motor not working

I was under the impression that if the resistor for the blower motor is bad that it will still work on high speed. I was wrong. The blower would not come on at all on any speed. I momentarily used a jumper wire across the diode in the resistor to check it and low and behold it started working. So it was the resistor after all.

Posted by on

Cars & Trucks Logo

Related Topics:

Related Questions:

1 Answer

my blower only will go on high and now its not working? but now its not working whats wrong i have no defrost or anything


Usually if your blower motor will work on high but not any of the other speeds then the blower motor speed resistor is at most likely fault. If the blower will no longer work at all you still may have a bad speed resistor but may also have a bad or corroded connector at the speed resistor or blower motor control switch, or even a blower motor that has finally failed. A blower motor that is pulling too many amps can damage the speed resistor, connector, and switch so I often also replace the blower motor whenever I find any of these other problems. Hope this helps and good luck!

Mar 29, 2011 | 1998 Plymouth Breeze

3 Answers

my lower fan speed don't work except for the high, the fan high speed stay highest


Hello sanjuis24
It sounds like you've got a bad blower motor resistor. The resistor is located under the right side of
the dash at the blower motor. A new resistor is not very expensive and it's a fairly easy DIY.
Hope this is helpful

Mar 07, 2011 | 2003 Chevrolet TrailBlazer

3 Answers

the heater squeels when on the high setting and does not work on any other setting I am trying to find an online guide on how to change the blower motor or is it the blower motor resistor? its for a 2002 chrystler town and country. Thanks


Blower motor is bad. Resistor controls speed. Motor is so worn out that it will only turn when set on high. Best to replace it before it burns out something else due to the high current draw.

Feb 02, 2011 | 2002 Chrysler Town & Country

1 Answer

The heater blower motor on a '92 transport has been replaced but quit working again. Is there a resistor that has possibly gone bad? And if so where is it located?


THE BLOWER MOTOR RESISTOR CONTROLS ALL SPEEDS EXCEPT HIGH . IF IT DOESN'T WORK ON ANY SPEED, IT MUST BE A BAD MOTOR, OR BAD FUSE OR A BAD SWITCH. IF YOU HAVE HIGH ONLY, THE RESISTOR MAY BE THE PROBLEM & IS PROBABLY UNDER THE DASH, NEAR THE BLOWER MOTOR.

Jan 05, 2011 | Pontiac Trans Sport Cars & Trucks

1 Answer

2006 silverado 5 speed heat, the high speed is not working. I do have the 4 lower speeds


The switch, high blower speed relay or the wire harness at the blower motor has gone bad. The highest setting 5 has no resistor, so the blower runs on high but the high current flow ends up burning up the switch's contact on that setting or the relay and may be the resistor wire harness at the blower motor has gone bad. Common would be the switch it self, if the switch is good. Then it's going to be the blower relay or wire leads at the speed resistor by the blower motor under the glove box by the passenger leg compartment. Keep me posted, be glad to help you get your Silverado running 100% again soon.

Jan 07, 2010 | 2006 Chevrolet Silverado 2500HD 2WD

Not finding what you are looking for?

2,117 people viewed this tip

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Loading...