Question about Polaris ATV

Open Question

2004 polaris magnum 330 4x4. no spark, put new coil on. no spark. have power going in to cdi , no spark. is the cdi bad?

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No spark on 2000 300 exsplorer atv


go to scribd.com and you can look at the service manual to diagnose the proceedure to check for spark

Oct 03, 2017 | Polaris ATV

1 Answer

1997 425 magnum 4x2 new carb,coil,plug,wont rev past halve throttle then sputters no power


Fuel starvation (supply or wrong carb or tune) and/or insufficient or poor quality spark.

Make sure the air filter is clean and only test with it connected as it sometimes makes a lot of difference. It could be worth checking the exhaust for blockages.

Feb 25, 2017 | Polaris ATV

2 Answers

My 1999 Polaris 250 trailblazer has no spark please help


Probably the ECM, if you have a good, charged battery, spark plug, wiring is not damaged, and kill switches are in "run".

May 02, 2015 | Polaris ATV

4 Answers

04 Polaris predator, I bought used last week. I put a new battery and new carb on it. It doesn't have power, won't start, and no spark with kick starter. Dead. Fuses,wires, look good. Any ideas


Did it have compression before you bought it?
No power to the electric starter? Then you probably have no power to the ignition system. I'd check battery connections. Is the battery going flat overnight? Some shorts. Is there an ignition with a key? Is the switch good? or all the connections good? Corrosion does some funny things. Fuses may look good but actually are not.

Apr 02, 2015 | ATVs

1 Answer

I have a 2003 polaris trailblazer 400. the oiler stopped working and fouled up my piston. I got it rebored and new piston. after that job was done i tried to start it. would not start. found that i had no...


fyi, something to watch out for on those is bad crank seals. will allow a lot of air in and cause the engine self destruct. before the cdi try simpler things like coil and making sure all the wiring is right. good pickup coil.

May 31, 2017 | Polaris ATV

2 Answers

2010 polaris sportsman 800 efi 67 miles on machine ran fine for 65 miles now when i push snow for 10 to 20 minutes it acts like it is runing on 1 cyclinder after i shut it off for while it runs fine my...


something is overheating, remove one sparkplug at a time and check for spark, be careful not to burn your self. Try 2 new plugs good luck

Jan 05, 2018 | Polaris ATV

1 Answer

Polaris 90 will not start...turns over but not firer


coil maybe bad. lots of reasons here
cdi maybe bad i would try boot on spark plug wire first screws off and back on with new one

Dec 05, 2017 | Polaris ATV

Not finding what you are looking for?
Polaris ATV Logo

Related Topics:

593 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

john h

Level 3 Expert

14398 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

297 Answers

Wade Mobley
Wade Mobley

Level 3 Expert

513 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...