Question about Polaris ATV

Open Question

2005 polaris 330 magnum 4x4. It is runing hot and

2005 polaris 330 magnum 4x4. It is runing hot and then cutting off. It is not the thermastat. The fan isnt running, but I wired it where it would run all the time now, and it still is running hot and then cutting off

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why will 2005 Polaris Magnum 330 fan not stop running when the ignition is turned off? The running fan drains the battery.


replace the faulty fan relay or check for a problem wire from the ignition to the sensor to the relay

Mar 03, 2016 | Polaris 2005 Magnum 330 4X2

1 Answer

The fan comes on immediately when the ignition is turned on, so I know it is not hot. What is likely the culprit?


To try to disconnect the plug of the temperature sensoron the engine block and turn the start. If the fans topped working, then the problem is in the temperature sensor

Oct 01, 2015 | Polaris 2004 Magnum 330 4X4

1 Answer

Where are the fuses on a 2001 Polaris 325 Magnum 4X4


Polaris 325 MAGNUM 4X4 HDS A00CD32FA Parts Manual

www.manualslib.com > ... > 325 MAGNUM 4X4 HDS A00CD32FA
View and Download Polaris 325 MAGNUM 4X4 HDS A00CD32FA parts manual online.Polaris Automobile Accessories Parts Manual. 325 MAGNUM 4X4 HDS ...

Aug 07, 2015 | Polaris ATV

1 Answer

04 330 magnum will not stay running without choke pulled out halfway to full choke from brand new in 2004


First make sure the carb.mounting flange is tight. being loose or cracked will allow air in leaning out the air fuel mixture. Next remove the low jet in the carb. its most likely plugged. try carb cleaner and blow it out with compressed air. Last resort,take the paper off of a twist tie and run it through the jet. If all else fails,buy a new one.thier only around 4 dollars.

Dec 14, 2014 | Polaris 2004 Magnum 330 4X4

1 Answer

Nothing works


Have you checked the fuse terminals coming off the battery there is a fuse some times it is a bad ground make sure battery is charged

Apr 15, 2014 | Polaris 2005 Magnum 330 4X4

1 Answer

I have no lights no dash and when I turn the key over nothing battery is good


Have the ignition module unit tested, I had one go bad and it did the same thing. Eric

Apr 07, 2014 | Polaris 2005 Magnum 330 4X4

1 Answer

Draw on Batt over night with all switvhes off


you might need a new battery from old age. also while its running check the battery voltage. should be around 17V, if not could be the voltage regulator.

Feb 13, 2014 | Polaris 2004 Magnum 330 4X4

Not finding what you are looking for?
Polaris ATV Logo

Related Topics:

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

john h

Level 3 Expert

12173 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

293 Answers

Wade Mobley
Wade Mobley

Level 3 Expert

462 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...