Question about Polaris ATV

1 Answer

Hi i just had my motor rebuit from the polaris dealer up and i brought it home with in 20 of starting it he temp light came on so a i thought it was the antfreeze but turns out they didnt fill any of the oils in it and i lost it on the couse the manul says it take oil in the motor and in the crank case and it was sad couse becouse the dealer up here told the bike dosnt take any oil it was injected threw the on the front of the bike so i was wondering if you guys could help me in area

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 472 Answers

I WOULD TAKE IT TO SOME ONE ELS AND IF THAY TELL YOU THAT IT NEEDS OIL THEN GO BACK TO THE OLD SHOP AND MAKE THEM FIX IT FOR NOTHING OR YOU WILL CALL THE BBB THATS WHAT I WOULD DO

Posted on Nov 20, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 08 Sportsman 500HO which the motor starts cutting out between 3600-4600 RPM's


Hi Tom:
Sounds like a challenge.
I'd probably check the ignition system if I thought the fuel supply was working properly.
Replace spark plugs - test run
If there is a manual hi speed adjust screw on the carb, have you tried adjusting it at high RPM?
reply as a comment to this post and I'll try to help.

Jun 17, 2016 | Polaris 2008 Sportsman 500 H.O

1 Answer

Wiring diagram for trail boss 250


Hi ! for an informantion,please visit the website below. If you need more information about a specific electrical issue you can reach me at motor@motorpartstore.com.
Motor Part Store Motor Parts Wholesale

May 03, 2016 | Polaris ATV

1 Answer

2007 Predator 500. How can I time it?


Hi ! for an informantion, please visit the website below. If you need more information about a specific electrical issue you can reach me at motor@motorpartstore.
Motor Part Store Motor Parts Wholesale

Apr 10, 2016 | Polaris ATV

1 Answer

Hard to shift out of 1st gear


hard to shift gears - Polaris ATV Forum

www.polarisatvforums.com > ... > Polaris Sportsman
Jun 28, 2010 - my 06 500 efi creeps and sometime is a little hard to shift. the dealer told me ... inline. if its off a little when you are stopped and trying to shift the tranny has... 2013 RZR XP 900 .... shop, for first service and to put in a new belt, blew up the firstone already. ... what makes a polaris crew hard to change gears.

Won't shift with motor running. Need help please - Polaris RZR ...

www.rzrforums.net > ... > General RZR > RZR-S Specific Discussion
Mar 6, 2012 - It will not shift in any gear with the motor running, but if I turn it off I can.... First Name: Jeanie ... 2013 Grizzly ... LE - Muzzy, UMP, Donaldson, TS Seats, FixMyToys parts.. and a lot of hard work .... 2005 polaris sportsman 500 shifter problems stuck in reverse ... polaris ranger 700 crew wont shift when running. How to adjust shifter
Nov 27, 2013
Issue: In gear, but will not drive
Oct 22, 2012
Gear Grinding
Oct 7, 2012
HELP trans is hard to shift
Jan 26, 2011
More results from www.rzrforums.net

Ranger Problems & Solutions [Archive] - PRC Polaris


Dec 30, 2015 | Polaris 2013 Ranger Crew 500

1 Answer

I have a code that makes no sense.Lo 010.8 Any idea what this means?


New 2012 850xp won't start - Polaris ATV Forum

www.polarisatvforums.com > ... > ATV Repair and Maintenance
Jul 29, 2012 - With only 6 miles and 2 hrs on my new 850 the battery was dead. ...Location: Mc Minnville TN ... 2012 Sportsman XP 850 H.O. .... code 10.8 on a 2012polaris 850 four atv ... Copyright ©2000 - 2015, vBulletin Solutions, Inc. Broke my first axle
Apr 20, 2015
Sportsman 570 with or witout EPF
Nov 10, 2013
BRAND NEW 850xp PROBLEMS!
Oct 16, 2010
More results from www.polarisatvforums.com

Thread: Lo 10.8 code - Polaris Ranger Club


Dec 25, 2015 | Polaris 2015 Sportsman 850 SP Base

1 Answer

Brand new 2013 Polaris Ranger 800 S EFI - Dealer had 16.8 hrs on it when I bought it, now with only 20 hours total, 3.2 hours from me, the drive belt eats itself. Dealer says it may not be covered by...


it sounds that this should be a waranty job as these should last for ages it sounds that the belts not lining up properly could be the motor is not right hieght or some other trouble,get in touch with the polaris clubs or some clubs that use these machines as they are the ones to know if there are problems about these. if you get no satisfaction from the dealer get in touch directly with polaris themselves. hope this helps cheers

Sep 23, 2013 | Polaris 2011 Ranger RZR 800 EPS Orange...

1 Answer

Idles great but open the throttle it misses and backfires


sounds like you have an air leak on the intake somewhere

Jul 12, 2017 | Polaris ATV

1 Answer

I have a 2006 polaris sportsman, 500 efi. Rolled atv over and got oil in the airbox. Cleaned airbox and ran fine for awhile. Developed a slight miss(mainly when warmed up) at initial throttle. It would...


Did you replace the air filter? Do that.
This sounds a little deep for "good advice" on here.. three dealers couldn't fix it...??? I have fixed bikes that other dealers couldn't in the past... this sounds like an issue that will be fixed by someone that has had this same experience...(that's how I did it!)
Good Luck!!!!

Apr 15, 2017 | Polaris ATV

4 Answers

2004 polaris sportsman 700, shuts off while riding.


I have a 2004 700 carb that shut off while riding and then would start up 3-5 minutes later after many nights working on it Ifinally figured it out no help from any dealer. There are 2 circuit breakers under the front rack mine were very rusted, Replaced both never had the problem again. My situation was always only when the lights were on.
Hope this helps

Aug 07, 2009 | Polaris ATV

Not finding what you are looking for?
Polaris ATV Logo

Related Topics:

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

john h

Level 3 Expert

12650 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

297 Answers

Wade Mobley
Wade Mobley

Level 3 Expert

489 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...