Question about Polaris ATV

1 Answer

1995 polaris 500 just riding along fine and it dies now no power

Turn on the key and nothing, no instrument, netrul, or head lights ( no power) wont start with pull start either.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 93 Answers

The battery is not charging up. Use a volt meter. Check the battery (12volts) and the charging system. With engine running and rev'd (14 volts).

Posted on Oct 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 2000 polaris scrambler 500 and only backfires and pops in reverse. drive has full powrer and starts great


your reverse over ride not working , u need to open switch box see if you have power to the switch when bike is running with a test light then with brake on and in reverse check the output wire to see if you have power out when depressed be sure you have the wheels up in the air when you do this for safety sake

Dec 31, 2016 | Polaris ATV

1 Answer

Why did lights go dim and battery died?


Search Results

    Battery Dead, runs but headlights dim - Polaris ATV Forum

    www.polarisatvforums.com > ... > Polaris Phoenix
    Jul 23, 2011 - Go Back · Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Phoenix ... Two days later the battery was dead. ... run ok, but the lights weredim and they did not brighten with I rev'ed it up. ... Polaris ATV Legend. Polaris 2500 winch draining battery
    Jan 9, 2014
    No Electrical Power when Key is turned. New Battery
    Dec 18, 2013
    elctrical nightmare!!!
    Feb 19, 2011
    Slowly Losing Power Only when hot...
    Oct 13, 2010
    More results from www.polarisatvforums.com

    Headlights dimming - ATVConnection.com ATV Enthusiast Community

    atvconnection.com/forums/polaris/326484-headlights-dimming.html
    Apr 25, 2010 - The lights on my 99 Sportsman 500 go from bright to dim all the time and I ... did you check the voltage yet when they do thid to make sure it's still putting out ... The Rectifier is my guess, I rode my ATV with a dead battery for a ... Battery Help
    Sep 6, 2014
    dim lights at idle - Page 3
    Dec 6, 2012
    2001 400 4x4 (manual) electrical problem(voltage)
    Aug 17, 2005
    Rancher Ignition Problems
    Dec 10, 2003
    More results from atvconnection.com

    charging issues - Honda ATV Forum

    www.hondaatvforums.net > ... > Honda TRX

Feb 03, 2016 | ATVs

1 Answer

My 2010 polaris 550xp head lights won't turn on


Start by checking your fuses, andcheck wiring harness to make sure nothing came unplugged or any wires cut.

Apr 28, 2015 | Polaris 2010 Sportsman 550

1 Answer

When i turn key gauge pod lights up but nothing else happens


neutral try connect battery terminals charge battery,starter hanging up

Aug 28, 2014 | Polaris 2006 Sportsman 500 HO EFI

1 Answer

Polaris troubleshooting


check ground at stater solenoid they are bad about corroding at frame but possible key switch is defective,also could be cdi box they recalled them check your vin, with dealer could be a free fix

Aug 17, 2014 | Polaris 2006 Sportsman 500 HO EFI

1 Answer

No power


check the main fuse on + line close to the battery or under the seat at the rear. sounds like thats your problem.

Jun 13, 2013 | Polaris 2006 Sportsman 500 HO

Not finding what you are looking for?
Polaris ATV Logo

Related Topics:

709 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

john h

Level 3 Expert

10993 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

293 Answers

yadayada
yadayada

Level 3 Expert

75005 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...