Question about Polaris ATV

1 Answer

Battery icon flashing

I have a 2005 POLARIS 330 Magnum.The battery icon on the display flashes but only when the atv is moving. After stopping and just let it idle the flashing stops. What could be wrong/

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Your Stator shorted out and is charging to hi, 17-18 volts. Turn your key off, put your brake on (on the left handle bar) lock in place. Push your override (yellow button on left handle bar) wait about 5-10 seconds, now turn on your key and start the bike. Keep pushing the overide button once v2.1 goes away and you'll get into the voltage of the bike. rev it up to 4 or 5000 rpm, what is the charge, my guess it is around 17 or 18 volts. rebuild your stator

Posted on Sep 05, 2009

Testimonial: "The volts were at 17.5 to 18.Thanks for your help,I'll be getting it fixed asap."

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I remove the race out of my polaris magnum 325 swing arm ? Should I buy a slide hammer?


Do you have access to a press? ... ask around.. or take it to a friend at an automotive shop.. you will save yourself some grief..

Oct 26, 2016 | Polaris 2004 Magnum 330 4X4

1 Answer

Why will 2005 Polaris Magnum 330 fan not stop running when the ignition is turned off? The running fan drains the battery.


replace the faulty fan relay or check for a problem wire from the ignition to the sensor to the relay

Mar 03, 2016 | Polaris 2005 Magnum 330 4X2

1 Answer

Nothing works


Have you checked the fuse terminals coming off the battery there is a fuse some times it is a bad ground make sure battery is charged

Apr 15, 2014 | Polaris 2005 Magnum 330 4X4

1 Answer

I have no lights no dash and when I turn the key over nothing battery is good


Have the ignition module unit tested, I had one go bad and it did the same thing. Eric

Apr 07, 2014 | Polaris 2005 Magnum 330 4X4

1 Answer

Draw on Batt over night with all switvhes off


you might need a new battery from old age. also while its running check the battery voltage. should be around 17V, if not could be the voltage regulator.

Feb 13, 2014 | Polaris 2004 Magnum 330 4X4

1 Answer

No awd only 2wd


If I remember right it does the little black box (not the CDI box) the 330 I replaced the control box on once i replaced the box the speedo did light up again been along time ago but I think if you repalce the control box it will fix your problem

Jan 31, 2014 | Polaris 2005 Magnum 330 4X4

Not finding what you are looking for?
Polaris ATV Logo

Related Topics:

758 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

john h

Level 3 Expert

12650 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

297 Answers

Wade Mobley
Wade Mobley

Level 3 Expert

489 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...