Question about kawasaki 2005 Mule 3010 4x4

1 Answer

Mule 3010 has no power. in low or high it goes maybe 9 mph, has new pump, spark plugs, checked the vents, nothing is helping

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • kawasaki Master
  • 3,482 Answers

What is the compression? This leads me to think you may have more of an internal issue.

Have the compression checked, with throttle wide open, then repost with the results.

Posted on May 31, 2017

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
claudeinmo
  • 9098 Answers

SOURCE: where is the neutral safety switch for a kawaski 3010 mule

Kawasaki Mule Update - YouTube

? 2:16
www.youtube.com/watch?v=Fw_jeQUU6Hw
Jan 25, 2013 - Uploaded by Penguinboy1995
solenoid is reading battery voltage and the constant hot, it is not sending the 12 volts from the switch to the ...

Posted on Sep 20, 2015

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2003 kawasaki mule model 3000 it wont say running at idle what to do


Full tune up and carb clean .get new plug,air filter.oil Chang ,carb clean and adjustment.that should do it.,., try fuel filters and test fuel pump see if it's functioning properly.,.

Dec 10, 2016 | kawasaki 2005 Mule 3010 4x4

1 Answer

Why do I keep having to replace the fuel pump?


Check your fuel filter! Fuel not being filtered properly is the main cause of fuel pump failure.

May 26, 2016 | kawasaki 2005 Mule 3010 4x4

1 Answer

Where is the neutral safety switch for a kawaski 3010 mule


Kawasaki Mule Update - YouTube

? 2:16
www.youtube.com/watch?v=Fw_jeQUU6Hw
Jan 25, 2013 - Uploaded by Penguinboy1995
solenoid is reading battery voltage and the constant hot, it is not sending the 12 volts from the switch to the ...

Sep 19, 2015 | kawasaki 2005 Mule 3010 Trans 4x4

1 Answer

What does Kawasaki mule 3010 do when belt breaks


makes all kinds of noise in houseing and if belt is not full broken will still go fwd

Sep 23, 2014 | kawasaki 2008 Mule 3010 Trans 4x4

1 Answer

What is possible cause that a mule 3010 kaf620e6f will not hold idle?


Air leak .dirty air filter.,.fouled plug.,.bad gas.,.dirty carb?fuel injection? Bad fuel filter ,fuel pump test fuel pump that's the general stuff.go from there

Apr 28, 2014 | kawasaki 2006 Mule 3010 4x4

1 Answer

Rear wheels lock up at high speeds


Sounds like a bent axle.... or something in the rear differential. ...the heat generated by the bent axle will cause all the clearances to disappear!!!

Jan 01, 2014 | kawasaki 2008 Mule 3010 Trans 4x4

1 Answer

Kawasaki mule 3010


Check the starter or solenoid.

Apr 27, 2013 | kawasaki 2008 Mule 3010 Trans 4x4

1 Answer

My 3010 diesel mule will not accelerate


Sounds to me that the fuel rack is gummed up will see if I still have info on this

Apr 21, 2013 | kawasaki 2005 Mule 3010 Diesel

1 Answer

Kawasaki Mule 1999 Model


Hello Anon..
First, I would check to make sure the carbs are getting fuel, and then fuel getting into the cylinders. Your question about low oil - did you let it get low and then it quit? ...
If you put oil into the cylinders and only got 100psi, this might be your problem. You should be pumping around 120+psi without putting anything into the cylinders... Recheck the compression.= .take out all spark plugs...screw the gauge in until the o-ring seats, hold the throttle wide open while spinning the engine over for about 5 seconds... you should get 120psi +/- 10psi.
If you are getting less than 100psi.. it might be time for a rebuild..

May 24, 2017 | kawasaki 2005 Mule 3010 Trans 4x4

Not finding what you are looking for?
kawasaki 2005 Mule 3010 4x4 Logo

Related Topics:

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki ATVs Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Lawrence Oravetz

Level 3 Expert

9742 Answers

Glenn Smart
Glenn Smart

Level 3 Expert

818 Answers

Are you a kawasaki ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...