Question about Yamaha ATVs

Open Question

Burning motor smell

Just smell a burning rubber smell on my Bruin 350. Don't have to run it long. and it's not summer, so it shouldn't be too hot.

Posted by Anonymous on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My husband has a 1998 350 4x4 Yamaha that is not firing


test: plug, spark plug cap, coil then stator pickup coil.

Apr 24, 2017 | Yamaha 2005 Bruin 350 Auto 4x4

1 Answer

I have a 2006 yamaha bruin 350. The other my son jumped started my daughters atv and it burned his ground wire up. Now have no fire goin to the coil. any suggestions


I am sure you have replaced the ground wire. Start checking everything from the battery on. Make sure all fuses are good. Sounds like it was jumped from a car, worse thing you can do especially it it is running. Could just be the coil. If not, cdi possible too. Are you getting power to all of your lights and everything now just no spark? If you can find a donor coil to check, make sure all of your grounds are good to the motor too. Google for testing specs on that model for the cdi.

Aug 03, 2015 | ATVs

1 Answer

Carb leaks out of tube under carb


Float valve in carb is leaking or the float is sticking allowing fuel to overfill the fuel bowl. If the engine runs well otherwise it is a quick fix with a carb kit. If possible run alcohol free fuel in all small engines. Saves a lot of problems.

Apr 28, 2014 | Yamaha 2005 Bruin 350 Auto 4x4

1 Answer

Where is the main fuse for a yamaha bruin 350 four wheeler


Close to the battery on thr red wire in a plastic cylindrical fuse holder.

Apr 23, 2014 | Yamaha 2005 Bruin 350 Auto 4x2

1 Answer

Wont idle without choke being used


Main jet dirty. Likely Ethanol fuel fouling. Remove and clean jet. Check all rubber tubing to/from carb for cracks/deterioration and replace.

Nov 24, 2013 | Yamaha 2004 Bruin 350 Auto 4x4

1 Answer

My Yamaha Bruin will only go about 12-15 mph at high rpm?


If it is a automatic transmission the drive belt may be worn out.

Nov 02, 2013 | Yamaha 2005 Bruin 350 Auto 4x4

2 Answers

Diagram for carb on 350 bruin


Hi, Anonymous and the usual suspects are:
1. Damaged or restricted fuel tank venting system.
2. Loose float bowl screws.
3. Damaged float bowl o-ring.
4. improper fuel level in the float bowl.
5. Worn or dirty inlet valve or seat.
6. Damaged or leaking float assembly.
7. Particle contamination in inlet fitting cavity.
Good luck and have a nice day.

Feb 13, 2013 | Yamaha 2005 Bruin 350 Auto 4x4

Not finding what you are looking for?
ATVs Logo

Related Topics:

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha ATVs Experts

 Scott Tx
Scott Tx

Level 2 Expert

552 Answers

Wayne McNeil

Level 2 Expert

168 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Yamaha ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...