Question about Suzuki 2007 KingQuad 700 4X4

1 Answer

2006 Suzuki King Quad sputters at high RPMs like it's breaking down. It starts good and seems to run alright except in high RPMs.

Changed the spark plug and cleaned everything.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Suzuki Master
  • 3,497 Answers

Make sure you have the CORRECT spark plug... use what the owners manual says... NGK..

. A non - resistor plug will make some motors sputter at high rpm's ...if the quad calls for a "R" plug..use one!

Posted on Apr 13, 2014

  • curtis chappel May 06, 2014

    check your air filter maybe dirty

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2013 Suzuki 750 King quad EFI will start but if you move the steering it shuts down. Also, when slowing to a stop, the bike stalls. Each time the bike stalls it immediately starts.


Sounds like you have a wire that is ALMOST broken or the insulation is worn off and grounding, or turning is pulling a wire loose from a connection. .. this type of problem is HARD to trace down sometimes... good luck

Sep 04, 2017 | Suzuki 2006 KingQuad 700 4X4

1 Answer

My king quad just quit when I was riding yesterday no sputter just died won't start fuel pump still works seems like no spark?? not sure I am mechanically challenged HELP


Pull plug hook it to wire and test for spark...place against bare metal and turn motor over,look at plug if u see spark ?? your good there if not try new plug could just be fouled., Then work your way through fuel system....

Dec 27, 2016 | ATVs

1 Answer

I have a 1995 Suzuki King Quad (LT-F4WDX). Wont accelerate when warmed up.


did you adjust the valves? check and make sure the fuel pump is putting out enough fuel, way past time to replace it. check your voltage too, the regulators in those are famous for dieing.

Dec 22, 2016 | ATVs

1 Answer

Suzuki king quad problems


Personally i would check and see if you have any water in the carb before anything. this seems to be a common prob.

Jul 23, 2014 | Suzuki 2006 KingQuad 700 4X4

1 Answer

2006 king quad brake dose not lite bulb ok


check the switches on your brake handle, broken wires, bad ground on the light.

Mar 15, 2014 | Suzuki 2006 KingQuad 700 4X4

1 Answer

Stalling


The CDI box could be bad or the coil could be breaking down so maybe a new coil would fix you up they only run around 20$ cdi box on the other hand can cost an easy 100$ or better you might also try changing the oil but make sure to buy kinda thick oil cause it's cold out

Jan 13, 2014 | Suzuki KingQuad 400 ASi 4X4 ATVs

1 Answer

2005 suzuki 700 king quad manuals


determine if you have spark and are getting fuel

May 04, 2013 | Suzuki 2005 KingQuad 700 4X4

1 Answer

Suzuki quad lt-z400 2004 model, turns over alright, but will not start. Can pull and start it or roll down hill and start. After it runs a while, it will start with the key. any ideas where to start to...


This description does sound like a battery that is running to flat or not charging enough to crank the machine, Assuming the down hill roll is a "clutch start". If you handy with a multi meter, just check the voltage on the battery, if it is not a maintenance free battery it might just need a top up. If it is still the original battery, you might just get away a couple of months or another year by reconditioning it.It might also have the charging cables being loose or worn depending on the use it has. Best wishes and good luck with the repair

Jan 07, 2018 | Suzuki 2005 QuadSport Z400

Not finding what you are looking for?
Suzuki 2007 KingQuad 700 4X4 Logo

652 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki ATVs Experts

yadayada
yadayada

Level 3 Expert

77499 Answers

Lawrence Oravetz

Level 3 Expert

10028 Answers

Brent Tischer

Level 1 Expert

26 Answers

Are you a Suzuki ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...