Question about Polaris 2011 Ranger RZR 800 S

1 Answer

Fan comes on as soon as you start it and the engine light is on runs fine

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 127 Answers

Fan sending unit or relay has failed

Posted on May 18, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

We have a 2011 Polaris RZR 800. It overheated this weekend and was spewing antifreeze and water out. Fan was running


if You are clogged with dirt the radiator and the temperature sensor is OK . You have to open the radiator cap and start the engine in a heated condition if of antifreeze go small bubbles , then you need to replace the gasket under the cylinder head

Apr 25, 2016 | ATVs

1 Answer

My 600 IQ WT check engine light is coming up in saven blinks. How do i reset this problem the machine runs fine


Hi ! for an informantion, please visit the website below. If you need more information about a specific electrical issue you can reach me at motor@motorpartstore.com.
Motor Part Store Motor Parts Wholesale

Apr 02, 2016 | ATVs

1 Answer

Why does engine overheating light come on after only a few minutes without fan ever turning on?


There are 2 sensors for temperature. One near T stat housing for ECU reading. Other one in water passage for the light. The ECU turns the fan on by tripping the fan relay. The light comes on to tell you it's too hot. Check fan to make sure it turns. Check fan fuse to make sure it's not blown. Unplug fan motor and hot wire it to make sure it runs. If it does, locate fan relay and swap it with one of the others with the same numbers on it to see if fan comes on when engine heats up. If fan cycles normally the temp light sensor is probably bad.

Sep 19, 2015 | Yamaha 2007 Grizzly 450 Auto 4x4

1 Answer

I have a 2004 polaris sportsman 500 when it gets hot it cuts off and back fires


Does the cooling fan ever run when the engine is hot? If not, you may have a problem with the fan thermostat.

For the record, spray carburetor cleaner does no good if it's sprayed on the outside of the carburetor with the engine running. That's not what it's for.

Jul 29, 2014 | Polaris 2004 Sportsman 500 H.O

1 Answer

05 Eiger 400 ATV


ok two reasons here. 1st being the oil temp sensor or wiring to it from fan.test sensor when eng light is on . wire to sensor must be disconnected..ohms test. to grnd on atv. open or closed. now retest when eng is cold same test as b4. open or closed? if different reading assume sensor is ok. check wiring same way. can do wires eng cold btw. should find a relay for the fan on atv also thats part 2. be a small prolly black box near battery compartment (dry location) (up high ) trace wire from fan to relay then to sensor . pretty simple there . same as b4 either open or closed when hot and different when cold is ok if different. as always CHECK FUSES FIRST. CONNECTIONS SECOND. 95 % electrical ......dirty / bad connections.

Jul 13, 2014 | ATVs

1 Answer

Suzuki eiger 400


Fan motor bad or thermo switch bad.you can test the fan, hook it to a battery if it runs than its the thermo switch

Jul 13, 2014 | ATVs

2 Answers

Fan not working on polaris 500 sportman


Check fuses and wiring connections also the fan could have burnt out

Apr 12, 2014 | ATVs

2 Answers

"engine hot" light flashes


Get codes from the dianbostic computer reader at Pep Boys/ Autozone etc. or the dealer.
This should tell you which sensor is out

Mar 19, 2014 | Polaris 2004 Sportsman 400

1 Answer

Four wheeler


You will have to get the cooling fan working before you look any further. It may be best to have a coolant system pressure test and a compression test done to eliminate engine fault also

Jul 28, 2013 | ATVs

Not finding what you are looking for?
Polaris 2011 Ranger RZR 800 S Logo

Related Topics:

351 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

john h

Level 3 Expert

12104 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

293 Answers

Wade Mobley
Wade Mobley

Level 3 Expert

462 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...