Question about Suzuki 2005 QuadSport Z400

Open Question

Where is spark plug on 500 suzuki quadmaster - Suzuki 2005 QuadSport Z400

Posted by Anonymous on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2005 suzuki lt-700a will not start will crank over but not starting fuel is going to fuel injector but not coming out of injector even though it's good


Have you checked to see if the spark plug is firing??
How do you know the "injector" is good?

Is the spark plug wet after you try to start it for a few minutes??

More info please...

Jan 05, 2017 | Suzuki 2005 KingQuad 700 4X4

1 Answer

Spark plug gap for a Polaris sportmans 500 a 2010 year


0.028

http://www.polarisatvforums.com/forums/atv-repair-maintenance/14769-spark-plug-gap.html

BKR6ES(STOCK#6364) regular, or IRIDIUM BKR6EIX(STOCK#6418).Gap setting is .028.
That plug is used on all 500 HO from 2000-2011 Sportsman Models.

http://www.polarisatvforums.com/forums/atv-repair-maintenance/40754-500ho-ngk-spark-plug-number.html

http://www.ngksparkplugs.ca/results-motorcycles.cfm?model=empty&enginesize=500&make=POLARIS&apptype=ATV

Here is your manual. Spark Plug page 93. Page 123 says
Spark Plug / Gap NGK BKR6E / .035 in. (0.9 mm)

Different plug (E rather than ES) and gap. check the plug that came out.

http://cdn.polarisindustries.com/polaris/common/parts-manuals/9923420r01_lo_res.pdf

Jul 10, 2016 | Polaris 2004 Sportsman 500 H.O

1 Answer

How to tell what year my suzuki quadmaster 50 is


LT50's are from 1984-87
LTA50's from 2002-05

May 12, 2015 | ATVs

1 Answer

2006 Suzuki King Quad sputters at high RPMs like it's breaking down. It starts good and seems to run alright except in high RPMs.


Make sure you have the CORRECT spark plug... use what the owners manual says... NGK..

. A non - resistor plug will make some motors sputter at high rpm's ...if the quad calls for a "R" plug..use one!

Mar 25, 2014 | Suzuki 2007 KingQuad 700 4X4

1 Answer

I have a john deere 500 buck atv when it gets hot shuts down and takes forever to get it started back


Take the coil and have it tested. Sounds like when the coil get warmed up it brakes down the secondary field. If you have a good none coil swap it out and see what happens. Also when it does this next time you are riding it pull the spark plug boot off and use a good spark plug grounded against the engine and see if you have spark.

Sep 15, 2013 | John Deere 2006 Buck 500

Not finding what you are looking for?
Suzuki 2005 QuadSport Z400 Logo

Related Topics:

285 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki ATVs Experts

Marvin
Marvin

Level 3 Expert

81400 Answers

Lawrence Oravetz

Level 3 Expert

10314 Answers

Brent Tischer

Level 1 Expert

26 Answers

Are you a Suzuki ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...