Question about Suzuki 2007 Eiger 400 4X4 Automatic

1 Answer

Bogs under a load or climbing hills

Seems like it bogs climbing hills and just don't have the power it should have. my buddy has 2 eigers and both of his runs better than mine any suggestions?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,807 Answers

Its an automatic, so im guessing its belt driven. Possibly worn belt/pully's/clutch.

Posted on Jul 28, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Finding the Speed omatder cable on my Suzuki eiger 2005 400 quad because the quad isn't reading my speed


If you have the front wheel off recently one, the speedometer sensor is easily broken and a common occurrence when the wheel is removed and replaced.
The symptoms are erratic or non-working speedo.
Also, there is a wiring harness under the speedometer. Remove the 3 bolts holding on the speedometer, and carefully lift it up and check to make sure the harness is plugged together tightly.

Jan 04, 2018 | Suzuki 2005 Eiger Automatic 400 4X4

1 Answer

2003 Suzuki eiger starter button doesn't do anything


Hey Brad
With the info you have provided, it seems to point to the ignition switch as the problem. (the clicking you should hear comes from the solenoid contacts - not the starter button). There is probably one wire in the switch that has broken or come unsoldered or other wise not making the right connection.

Jun 12, 2017 | Suzuki 2004 Eiger 400 4X4 Manual

1 Answer

I have an 04 Suzuki Eiger 400. Smokes a lot when first started but subsides a little after running. Im thinking piston rings but would like any other feedback before tearing the top end apart


sounds like piston rings, if rings are in bad shape,will be at its worst when cold then will get better when it warms up. Should be some power loss as well. pretty easy rebuild. good luck

Apr 13, 2014 | Suzuki 2004 Eiger 400 4X4 Manual

1 Answer

Eiger problems suzuki


Make sure you didn't accidentally move the Run/Stop switch to the Stop position!

May 18, 2013 | Suzuki 2005 Eiger Automatic 400 4X4...

1 Answer

Suzuki eiger 400


could be the pickup coil, the cdi or any of the wiring in between.

May 03, 2013 | Suzuki 2006 Eiger Automatic 400 4X4...

2 Answers

My 2007 suzuki Eiger 400 4X4 will not move when shifted into gear forward or reverse


if its a CVT the belt might be broke or worn. If a manual then it could be the centrifugal clutches

Apr 14, 2013 | Suzuki 2007 Eiger 400 4X4 Semi-Automatic...

Not finding what you are looking for?
Suzuki 2007 Eiger 400 4X4 Automatic Logo

Related Topics:

485 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki ATVs Experts

yadayada
yadayada

Level 3 Expert

80637 Answers

Lawrence Oravetz

Level 3 Expert

10291 Answers

Brent Tischer

Level 1 Expert

26 Answers

Are you a Suzuki ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...