Question about Polaris ATV

Open Question

I have a 2005 sportsman 400 tach and odometer doesnt work and it won't start just clicks

Fuel gauge and rpm gauge works fine trip meter odometer and tach does not work not sure if there is any connection with it not starting also 4x4 doesn't always work

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 2 Answers

SOURCE: 2005 Polaris 700 sportsman 4x4 gets warm, looses power?

My 2005 700 efi is doing the same thing. So far I have found that the engine and exhaust get so hot that the fuel starts to boil and causes the fuel pump to vapor lock. I taped up the tank with some reflective tape/insulator stuff and now I'm trying to figure out why its running so hot.(The exhaust manifold glows red hot) I've cleaned the radiator and flushed the system. I just need to check the water pump and thermostat. Any other suggestions?

Posted on Sep 02, 2009

  • 1 Answer

SOURCE: 2001 Polaris sportsman 500 magnum 4x4, speedo dont work

I'm not sure but it might be the sensor on the right front wheel disk

Posted on Sep 05, 2009

  • 1 Answer

SOURCE: overheating polaris sportsman 700

you probly need a new heat sensor, its located on the bottom right of your rad, i had the same problem with my 700 the fan only worked when it was already over heating, i cut the wires flush at the sensor drilled a hole above the key switch and mounted a toggle switch, no more over heating,

Posted on Oct 24, 2009

  • 5 Answers

SOURCE: The solenoid clicks when i turn the key

bad silinoid or bad battery

Posted on Jan 26, 2010

  • 64 Answers

SOURCE: 2004 sportsman 400 4x4 shifts late and hard going into high end

polaris drives are variable speed. they only have 2 ranges plus reverse. it sounds like either the driven clutch is slipping or the trans is slipping. the gear cogs inside may not be locking in properly and the shifter rods may need adjustment.

Posted on May 04, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 08 Sportsman 500HO which the motor starts cutting out between 3600-4600 RPM's


Hi Tom:
Sounds like a challenge.
I'd probably check the ignition system if I thought the fuel supply was working properly.
Replace spark plugs - test run
If there is a manual hi speed adjust screw on the carb, have you tried adjusting it at high RPM?
reply as a comment to this post and I'll try to help.

Jun 17, 2016 | Polaris 2008 Sportsman 500 H.O

2 Answers

Fuel gauge flashes need fuel most of the time


Gary, Faulty fuel pump sending unit. Most of the forums I checked say this a big problem with Polaris, most say the pump and sending unit have to be bought as a assembly.
Check the attached links,instruction and guides, Good luck
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info."

08 800 sportsman fuel gauge not reading correctly

Guide to Servicing the Fuel Pump Gauge Regulator 2006 Sportsman 700 EFI

Polaris Sportsman 700 fuel gauge fix

Inaccurate Fuel Gauge Fix Flashing Fuel Indicator

Mar 31, 2016 | Polaris 2008 Sportsman 500 EFI X2

1 Answer

Why does my Sportsman 400 start by the pull cord, but will not start with the ignition. It turns over fine.


replace the battery as there is not enough charge to start and provide power for the ignition
when you pull start the max power is provided to the ignition system

Mar 22, 2015 | Polaris 2004 Sportsman 400

1 Answer

Starts with prime or starting fluid wont stay running good gas flow to injector


You need to put a gauge on your fuel pump to test your fuel psi just because you have gas to your injector doesn't mean you have the right amount of pressure.

Feb 22, 2015 | Polaris 2005 Sportsman 500 H.O

1 Answer

Have a ploaris 400 2005 turns on runs great for bout 20 minutes then shuts down. wait bout 15 minutes will start and run again for a short time. What is the problem


most likely a fuel issue. has it been sitting up ? if so if its got a carb it prob gummed up, pour some seafoam into the gas tank with fresh gas and run it, try and keep it running with the throttle, it might clear some varnish out the carb if it not too bad, if tht dont work and it is a carb engine then the carb will have to be removed and cleaned. if it a FI engine then you got a bad full pump more than likely

Oct 01, 2014 | Polaris 2005 Sportsman 400

1 Answer

How to tell if seloid bad?


You can check a solenoid by using an ohm meter. Or just take it to a auto shop and ask them to check it for you if you don't have one. They can check it real quick and shouldn't charge you anything.

Aug 03, 2014 | Polaris 2004 Sportsman 400

1 Answer

Should screen show what gear the machine is ina 2005 sportsman 400


The Display screen on your Speedometer should indicate if you are in P , N , L or H .It should also indicate if you are in 2 or 4WD

Oct 23, 2013 | Polaris 2005 Sportsman 400

1 Answer

2004 sportsman 400 4x4 shuts off after running for while. Blow air into the flue tank and will run again.


It appears that you have fuel venting problem or a float level set too high. Check the entire fuel system for kinked / blocked fuel lines/ filters and check the float level or fuel manifold pressure if it has one.

Jun 28, 2013 | Polaris 2004 Sportsman 400

1 Answer

I have a polaris 400 sportsman atv. I haven't started it in 2 plus years, the battery is fully charged, it will not start. I put some gas in the tank.


you probably dont have a fuel pump issue, atv's after sitting have a problem of not starting due to carb gumming up. if its fuel injected, then i would say poss fuel pump but if not, the carb gummed is more than likey the issue.

Apr 01, 2013 | Polaris 2004 Sportsman 400

Not finding what you are looking for?
Polaris ATV Logo

Related Topics:

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris ATVs Experts

john h

Level 3 Expert

11034 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

293 Answers

yadayada
yadayada

Level 3 Expert

75051 Answers

Are you a Polaris ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...